Pada halaman ini kita akan menkonfigurasi Ether chennel pada perangkat cisco. Apa itu Ether Cheanel? EtherChannel adalah fitur pada perangkat jaringan Cisco yang memungkinkan Anda menggabungkan beberapa link fisik Ethernet menjadi satu link logika tunggal. Biasanya ini digunakan dalam interface trunk (switch antar switch) yang digunakan untuk meningkatkan bandwidth atau Redundansi
Dalam konfigurasi EtherChannel, terdapat tiga cara untuk mengkonfigurasi protokolnya
dengan agregasi link menggunakan PAgP (Port Aggregation Protocol) yang merupakan protokol proprietary Cisco atau menggunakan LACP protokol standar (IEEE 802.3ad).
atau juga kita dapat menkonfigurasi secara manual Static.Berikut adalah syntac dalam konfigurasi ether channel.
Berikut adalah syntax konfigurasi ether channel:
interface range <interfaces range>
switchport mode trunk
channel-group <number> mode <protocol>
Tergantung dengan mode apa yang digunakan dalam kedua link yang dapat memutuskan link terbentuk ether channel atau tidak.
Contoh:
Switch#interface range FastEthernet0/1 - 2
Switch(config-ifrange)#switchport mode trunk
Switch(config-ifrange)#channel-group 1 mode desirable
show etherchannel summary
show etherchannel port-channel <port-channel number>
hostname MLS1
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
no shutdown
!
hostname MLS2
!
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool LAN2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
!
!
interface Vlan1
ip address 192.168.2.1 255.255.255.0
no shutdown
!
SW1(config)#interface range ethernet 0/0 - 1
SW1(config-if-range)#switchport trunk encapsulation dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#channel-group 1 mode active
MLS1(config)#interface range ethernet 0/2 - 3
MLS1(config-if-range)#switchport trunk encapsulation dot1q
MLS1(config-if-range)#switchport mode trunk
MLS1(config-if-range)#channel-group 1 mode active
MLS1(config-if-range)#exit
SW2(config)#interface range ethernet 0/0 - 1
SW2(config-if-range)#channel-group 1 mode desirable
MLS2(config)#interface Port-Channel 1
MLS2(config-if)#switchport trunk encapsulation dot1q
MLS2(config-if)#switchport mode trunk
MLS2(config)#interface range ethernet 0/2-3
MLS2(config-if-range)#switchport trunk encapsulation dot1q
MLS2(config-if-range)#switchport mode trunk
MLS2(config-if-range)#channel-group 1 mode desirable
MLS1(config)#interface range ethernet 0/0 - 1
MLS1(config-if-range)#no switchport
MLS1(config-if-range)#channel-group 2 mode on
Creating a port-channel interface Port-channel 2
MLS1(config-if-range)#exit
MLS1(config)#interface Port-Channel 2
MLS1(config-if)#ip address 10.0.0.1 255.255.255.252
MLS2(config)#interface range ethernet 0/0 - 1
MLS2(config-if-range)#no switchport
MLS2(config-if-range)#channel-group 2 mode on
Creating a port-channel interface Port-channel 2
MLS2(config-if-range)#exit
MLS2(config)#interface port-channel 2
MLS2(config-if)#ip address 10.0.0.2 255.255.255.252
MLS1(config)#ip routing
MLS1(config)#ip route 192.168.2.0 255.255.255.0 10.0.0.2
MLS2(config)#ip routing
MLS2(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1
PC1> ip dhcp
DORA IP 192.168.1.4/24 GW 192.168.1.1
PC1> ping 192.168.2.2
84 bytes from 192.168.2.2 icmp_seq=1 ttl=62 time=3.365 ms
84 bytes from 192.168.2.2 icmp_seq=2 ttl=62 time=1.824 ms
84 bytes from 192.168.2.2 icmp_seq=3 ttl=62 time=2.193 ms
84 bytes from 192.168.2.2 icmp_seq=4 ttl=62 time=2.082 ms
84 bytes from 192.168.2.2 icmp_seq=5 ttl=62 time=2.116 ms
PC1> trace 192.168.2.2
trace to 192.168.2.2, 8 hops max, press Ctrl+C to stop
1 192.168.1.1 1.079 ms 0.725 ms 0.724 ms
2 10.0.0.2 1.328 ms 1.116 ms 1.100 ms
3 *192.168.2.2 1.595 ms (ICMP type:3, code:3, Destination port unreachable)
PC2> ip dhcp
DDORA IP 192.168.1.5/24 GW 192.168.1.1
PC2> ping 192.168.2.2
84 bytes from 192.168.2.2 icmp_seq=1 ttl=62 time=2.208 ms
84 bytes from 192.168.2.2 icmp_seq=2 ttl=62 time=1.843 ms
84 bytes from 192.168.2.2 icmp_seq=3 ttl=62 time=2.169 ms
84 bytes from 192.168.2.2 icmp_seq=4 ttl=62 time=2.413 ms
84 bytes from 192.168.2.2 icmp_seq=5 ttl=62 time=2.028 ms
PC2> trace 192.168.2.2
trace to 192.168.2.2, 8 hops max, press Ctrl+C to stop
1 192.168.1.1 0.942 ms 0.671 ms 0.672 ms
2 10.0.0.2 1.183 ms 1.223 ms 1.034 ms
3 *192.168.2.2 2.217 ms (ICMP type:3, code:3, Destination port unreachable)
Server> ip dhcp
DORA IP 192.168.2.2/24 GW 192.168.2.1
Server> ping 192.168.1.5
84 bytes from 192.168.1.5 icmp_seq=1 ttl=62 time=2.272 ms
84 bytes from 192.168.1.5 icmp_seq=2 ttl=62 time=2.111 ms
84 bytes from 192.168.1.5 icmp_seq=3 ttl=62 time=1.958 ms
84 bytes from 192.168.1.5 icmp_seq=4 ttl=62 time=2.112 ms
84 bytes from 192.168.1.5 icmp_seq=5 ttl=62 time=2.023 ms
Server> trace 192.168.1.5
trace to 192.168.1.5, 8 hops max, press Ctrl+C to stop
1 192.168.2.1 0.552 ms 0.370 ms 0.331 ms
2 10.0.0.1 0.962 ms 0.691 ms 0.934 ms
3 *192.168.1.5 1.634 ms (ICMP type:3, code:3, Destination port unreachable)
MLS1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator
M - not in use, minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
A - formed by Auto LAG
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Et0/2(P) Et0/3(P)
2 Po2(RU) - Et0/0(P) Et0/1(P)
MLS2#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator
M - not in use, minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
A - formed by Auto LAG
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Et0/2(P) Et0/3(P)
2 Po2(RU) - Et0/0(P) Et0/1(P)