Point-to-Point Protocol over Ethernet (PPPoE) adalah salah satu metode populer untuk menyediakan koneksi internet berbasis akses dial-up pada jaringan ethernet. PPPoE menggabungkan protokol PPP dengan Ethernet untuk memungkinkan autentikasi, enkripsi, dan pengaturan IP secara dinamis, sehingga cocok untuk layanan ISP dan koneksi pengguna akhir.
Dalam Halaman ini, kita akan membuat konfigurasi PPPoE server pada MikroTik-ISP dan menyiapkan dua client yang akan terhubung melalui PPPoE (MikroTik-Client-1/MikroTik-Client-2)
/system identity
set name=MikroTik-ISP
/ip dhcp-client
add disabled=no interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/system identity
set name=MikroTik-Client-1
/system identity
set name=MikroTik-Client-2
/ip pool
add name=pool-pppoe ranges=172.16.1.2-172.16.1.254
/ppp profile
add name=pppop-profil local-address=172.16.1.1 remote-address=pool-pppoe \
use-encryption=yes
/ppp secret
add name=client1 password=password service=pppoe profile=pppoe-profile
add name=client2 password=password service=pppoe profile=pppoe-profile
/interface pppoe-server server
add service-name=service1 disabled=no default-profile=pppoe-profile interface=ether2
/interface pppoe-client
add disabled=no name=pppoe-out1 interface=ether1 user=client1 password=password add-default-route=yes use-peer-dns=yes
/interface pppoe-client
add disabled=no name=pppoe-out1 interface=ether1 user=client2 password=password add-default-route=yes use-peer-dns=yes
[admin@MikroTik-ISP] > ip address print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK INTERFACE
1 D 10.0.137.203/24 10.0.137.0 ether1
2 D 172.16.1.1/32 172.16.1.254 <pppoe-client1>
3 D 172.16.1.1/32 172.16.1.253 <pppoe-client2>
[admin@MikroTik-Client-2] > interface/pppoe-client/print
Flags: X - disabled, I - invalid; R - running
0 R name="pppoe-out1" max-mtu=auto max-mru=auto mrru=disabled interface=ether1
user="client2" password="password" profile=default keepalive-timeout=10
service-name="" ac-name="" add-default-route=yes default-route-distance=1
dial-on-demand=no use-peer-dns=yes allow=pap,chap,mschap1,mschap2
[admin@MikroTik-Client-2] > ip address print
Flags: D - DYNAMIC
Columns: ADDRESS, NETWORK, INTERFACE
# ADDRESS NETWORK INTERFACE
1 D 172.16.1.253/32 172.16.1.1 pppoe-out1
[admin@MikroTik-Client-2] > ping google.com
SEQ HOST SIZE TTL TIME STATUS
0 142.251.12.139 56 101 186ms237us
1 142.251.12.139 56 101 77ms971us
2 142.251.12.139 56 101 225ms549us
3 142.251.12.139 56 101 140ms95us
4 142.251.12.139 56 101 64ms174us
5 142.251.12.139 56 101 74ms979us
6 142.251.12.139 56 101 119ms202us
7 142.251.12.139 56 101 228ms847us
8 142.251.12.139 56 101 251ms630us
9 142.251.12.139 56 101 73ms538us
10 142.251.12.139 56 101 82ms768us
11 142.251.12.139 56 101 70ms83us
12 142.251.12.139 56 101 125ms923us
sent=13 received=13 packet-loss=0% min-rtt=64ms174us avg-rtt=132ms384us
max-rtt=251ms630us